Menu Cours OfpptLes Exposés INFOMotr Depanneur FrigoristeExposéé Asp.Net 2TDIInfographieRéseaux InformatiquesProjets ProgrammationReparateur FrigoristeTSRFCurriculum VitaeModules TSDITSTRIFilière TechnicienProcéduresRéseaux InformatiquesTMSIR ElectromecaniqueGéomètre TopographeJob Search USAlettre de motivationMécanique GénéralL'ELECTRONIQUE كتاب Modules TER et TSCExaman TDITSGE et TSGNe9la TSG et TCECours TCEElectrotechnique TSEالجامعات الأمريكيةGuide De Stageالجامعات المغربيةالجامعات الفرنسيةTREM السنة الأولىL’entretienExamine TDBTCVVPRU.S. Community CollegesCondition D'accesDévelopp MultimédiaMaintenance Hoteliere TMH3D Aburame Shinorecharge gratuitExamens TSCLes Projets INFOControles TPs - ExLes Modules TSRIPHP et MySQLXHTML et CSSFroid IndustrielBE Contruction Métalliquedrapo de mondeTREM دروس التكوين Examens electromecaniCommunicationTechniques l'ingénieurDevlopement INFOExamens TSTRIExamens TSGEChef De Chantierكتب لغات البرمجةCours TSMIRملف الترشيحElectricité ISTAAutoCad 2013 حملTS Thermique IndustrielleESAT CUISINE RFSLetters De MotivationExamens ISTALes CV ExemplesRapports De StageLes Entretien Examens TDIExamens ISTAالصحف المغربيةمواقع التشغيلغرفة النقاش الجادمواقع مغربية مهمةDessin de BatimentExploitation en TransportFabrication Mécanique TFMالتسجيل مفتوحConducteur De TravauxSecrétariat de DirectionSecrétariat BureautiqueRéseaux InformatiquesInfographieImpression et FinitionGestion Hôtelière TSGHGestion des EntreprisesDévelopp InformatiqueCommerce TSCComptabilite entrepriseAgent Technique DeVPresentation De L'OFPPTAnimation TouristiqueGros Oeuvresالدعـــم المباشــــرالأعمال التطبيقية - TREMسنة ثانية - TREM دروسسنة أولى - TREM دروس

Les tableaux

Les variables dimensionnées (Les tableaux)

 
Exercice 1 :
 
Ecrire un algorithme permettant  d’entrer cinq valeurs réelles au clavier,les stocker dans un tableau, calculer leur somme et les afficher avec leur somme à l’ecran.
 
 
Solution :
Algorithme  tableau_somme;
Var
              V   : tableau [1..5] de réels ;
              S   :  réel ;
i  :entier;
Debut
                (*lecture  des élements  du tableau*)
                Pour i <--  1 à 5 faire
                               Ecrire(‘entrer l’element  N° ’,i);
                               Lire(V[i]) ;
                Finpour i
                (*calcul de la somme des élements du tableau *)
                S <--  0 ;
Pour i <--  1 à 5 faire
                               S <--  S + V[i] ;
                Finpour i
(*afficher des éléments du tableau *)
                Pour i <--  1 à 5 faire
                               Ecrire(‘l’’element  N° ’,i,’est : ‘,V[i]);
                Finpour i
                Ecrire(‘la somme des éléments du tableau est :‘,S) ;
fin
 
Exercice 2 :
 
Ecrire un algorithme permettant  de saisir et d’afficher N éléments d’un tableau.
 
 
Solution :
Algorithme  saisie_affichage;
Var
              T   : tableau [1..100] de réels ;
              N,i   :  réel ;
Debut
                Ecrire(‘entrer le nombre d’éléments du tableau :’) ;
                Lire(N) ;
                (*lecture  des élements  du tableau*)
                Pour i <--  1 à N faire
                               Ecrire(‘entrer l’element  N° ’,i);
                               Lire(T[i]) ;
                Finpour i
(*afficher des éléments du tableau *)
                Pour i <--  1 à N faire
                               Ecrire(‘l’’element  T[’,i,’] est : ‘,T[i]);
                Finpour i
Fin
 
 
Exercice 3 :
 
Ecrire un algorithme permettant  de calculer la somme,produit et moyenne des  éléments d’un tableau.
 
 
Solution :
Algorithme  somme_produit_moyenne;
Var
              T   : tableau [1..100] de réels ;
              N,i   :  entiers ;
                S,P,M :  réels ;
Debut
                Si N=0 alors
                               Ecrire(‘le tableau est vide ‘) ;
                Sinon
                         S <--  0 ;
                         P <--  1 ;
                         Pour i <--  1 à N faire
                               S <--  S+T[i] ;
                               P <--  P * T[i] ;
                           Finpour i
                           M <--  S/N ;
                            Ecrire(‘la somme des éléments du tableau est : ‘,S);
                Ecrire(‘le produit des éléments du tableau est : ‘,P);
                Ecrire(‘la  moyenne des éléments du tableau est : ‘,M);
Finsi
Fin
 
 
Exercice 4 :
 
Ecrire un algorithme permettant  de consulter un  élément d’un tableau.
 
 
Solution :
Algorithme  consultation;
Var
              T   : tableau [1..100] de réels ;
              N,P   :  entiers ;
Debut
                Si N=0 alors
                        Ecrire(‘le tableau est vide ‘) ;
                Sinon
                        Ecrire(‘entrer l’’indice de l’’élément à consulter :’) ;
                        Lire(P) ;
                        Si (P<1) ou (P>N) alors
                                Ecrire(‘Position hors limites du tableau ‘) 
                        Sinon
                                Ecrire(‘l’’élément à consulter est :’,T[P]) ;
                         Finsi
                Finsi
Fin
 
Exercice 5 :
 
Ecrire un algorithme permettant  de chercher toutes les occurrences d’un  élément  dans un tableau.
 
 
Solution :
Algorithme  recherche_toutes_occurences ;
Var
              T   : tableau [1..100] de réels ;
              N,i   :  entiers ;
                X : réel ;
                Existe : booléen ;
Debut
                Si N=0 alors
                               Ecrire(‘le tableau est vide ‘) ;
                Sinon
                        Ecrire(‘entrer la valeur de l’’élément à chercher  :’) ;
                        Lire(X) ;
                        Existe <--  Faux ;
                        Pour i <--  1  à N  Faire
                                Si T[i] = X alors
                                               Existe <--  Vrai ;
                                               Ecrire(‘l’’élément à chercher apparait à la position : ‘,i) ;
                                Finsi
                         Finpour i
                         Si Existe = Faux alors
                                   Ecrire(‘l’’élément n’’apparait pas dans ce tableau ‘) ;
                           Finsi
                 Finsi
Fin
 
Exercice 6 :
 
Ecrire un algorithme permettant  de chercher  la première occurrence d’un élément dans un tableau.
 
 
Solution :
Algorithme  recherche_première_occurence ;
Var
T   : tableau [1..100] de réels ;
             P, N,i   :  entiers ;
                X : réel ;
                Existe : booléen ;
Debut
                Si N=0 alors
                               Ecrire(‘le tableau est vide ‘) ;
                Sinon
                        Ecrire(‘entrer la valeur de l’’élément à chercher  :’) ;
                        Lire(X) ;
                        Existe <--  Faux ;
                        i <--  1 ;
                        tantque  (i<=N) et (Existe=Faux) Faire
                                Si T[i] = X alors
                                               Existe <--  Vrai ;
                                               P<--  i ;
                                Sinon
                                               i ßi+1 ;
                                Finsi
                       Fintantque
                       Si Existe = vrai alors
                                Ecrire(‘la première occurrence de l’élément dans ce tableau est :’,P) ;
                       Sinon
                                Ecrire(‘l’’élément n’’apparait pas dans ce tableau ‘) ;
                      Finsi
                Finsi
Fin
 
Exercice 7 :
 
Ecrire un algorithme permettant  de chercher  la dernière occurrence d’un élément dans un tableau.
 
 
Solution :
Algorithme  recherche_derniere_occurence ;
Var
T   : tableau [1..100] de réels ;
             P, N,i   :  entiers ;
                X : réel ;
                Existe : booléen ;
Debut